System Requirements

In order to get the best Balto experience, here's an overview of the recommended settings that we advise you to use.


Web Dashboard

Recommended browser

macOS's latest version of Chrome

Browser that's not compatible

macOS's Safari 

Android app

Compatible with OS

Android 4.1 or later
Note: In order to be able to record 6-second video clips, you'll need version 5.0 or later.


iOS app

Compatible with OS

iOS 9.0 or later
Balto can be used on the following devices: iPhone, iPad and the iPod touch.


The Japanese version of this article can be found here: https://balto-ja.helpscoutdocs.com/article/79-recommended-settings

Still need help? Contact Us Contact Us